Extended Care Server Incident

Incident Report for ExtendedCare Cloud

Resolved

This incident has been resolved.
Posted May 19, 2025 - 19:50 CDT

Monitoring

Root cause of the issue is still being determined, but new servers have been brought online and customers should begin seeing more successful video visits. In the meantime we will continue to monitor.
Posted May 19, 2025 - 18:03 CDT

Investigating

We are currently investigating an issue with Extended Care
Posted May 19, 2025 - 16:24 CDT
This incident affected: ExtendedCare Core Services and ExtendedCare Admin Portal.